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Purpose 
The purpose of this document is to guide authors in correctly tagging PDF documents based on WCAG 
2.0. 

Introduction 
Original section 508 standards did not explicitly provide technical standards for electronic documents. 
Refreshed standards explicitly include electronic documents in addition to enhanced standards, WCAG 
2.0, many which are also mapped to current standards. All public facing documents are required to be 
compliant when posted to a site, distributed across the agency, or used as a sole means of information.  

In order for a PDF to be accessible, both the content and the back end structure must be free from 
issues that would alter or block information to users with disabilities. In PDF’s, the back end structure is 
referred to as the Tag structure and it allows Assistive Technology (AT) users a way to interpret the 
content of the document in the same manner of a visual user. 

This guide aims to help authors of PDF’s as well as those tasked with reviewing PDF’s to ensure WCAG 
2.0 and thus 508 compliance by showing the basic steps for tagging a PDF.  

Notes:  

• Fillable forms are out of scope for this document. 
• The screenshots in this guide are from Acrobat XI and may appear different in other versions, 

however the concepts are universal 
• Only correct examples are given, but a full list of HHS Common Accessibility issues to avoid for 

PDF can be helpful to review. 
• This course assumes ‘Creating Accessible Office Documents’ was already taken as a prerequisite. 

As such, if you are tagging a PDF where you did not author the content, or use a different 
program other than Office, it’s best to do a quick sweep to ensure the document is free from 
other 508 issues that would require a visual change including: 

o A complex image lacking an alternate description 
o Low color contrast of text 
o Conveying information with color only 

• Certain WCAG 2.0 guidelines do not apply because of a stated exception, these are: 
o 2.4.1 Bypass Blocks;  
o 2.4.5 Multiple Ways;  
o 3.2.3 Consistent Navigation; 
o 3.2.4 Consistent Identification. 

  

http://www.access-board.gov/guidelines-and-standards/communications-and-it/about-the-ict-refresh
http://www.access-board.gov/guidelines-and-standards/communications-and-it/about-the-ict-refresh/background/comparison-table-of-wcag2-to-existing-508-standards?highlight=WyJlcXVpdmFsZW50Il0=
http://www.hhs.gov/web/section-508/making-files-accessible/pdf-required/index.html
http://www.hhs.gov/web/section-508/making-files-accessible/pdf-required/index.html
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Document Properties and General Settings 
Certain settings must be configured in Acrobat to ensure the file meets HHS standards and to pass the 
built in Accessibility Checker tool. Fully passing the accessibility checker is required for compliance.  

Add/Modify Document Properties: 
1. From the Menu bar select “File” and choose “Properties.” 
2. Under the Document Properties, Select the “Description" tab. 
3. Add/Modify the following properties 

a. Title: The title of the document.  
b. Author: Your Agency/Division/Office (not a person)  
c. Subject: Brief identification of the subject of the document 
d. Keywords: Use any word or phrase important in the content of your document.  

 

Setting the Language 

1. From the Menu bar select “File” and choose “Properties”. 
2. Under the Document Properties, Select the “Advanced tab”. 
3. Select the Language under the dropdown menu and click OK. 
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Defining the Tab Order 

1. Select the pages icon  
2. Select all pages in the document 
3. Right Click and select “Page properties” 
4. From the “Tab order” panel select the “Use Document Structure” radio button 

 
5. Select OK 

Showing the Document Title 

1. From the Menu bar select “File” and choose “Properties”. 
2. Under the Document Properties, Select the “Initial View” tab. 
3. For the Show dropdown, select “Document Title” 
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Introducing and setting the tag structure 
PDF tags provide a hidden structured, textual representation of the PDF content that is presented to 
screen readers. For example, documents that have visual lists can be tagged with list tags, documents 
that have visual data tables can be tagged with table tags, etc. They exist for accessibility purposes only 
and have no visible effect on the PDF file. When a PDF is created from an office file, initial tags will be 
generated based on the content of the office file and the styles used.  

Throughout the rest of this document, multiple methods for the same action may be shown. This is 
because tagging the content can be very sensitive, especially with complex documents, so one method 
may yield different results than the other.  

Locating and understanding the tags panel 

By default, the tags icon should be available on the far left pane, which at that point it can be selected. 

 

 If for some reason the icon does not appear: 

Choose View > Show/Hide > Navigation Panels > Tags. 

 

The Tags panel will then display. Individual tags can be expanded one by one with the plus sign or all 
tags can be expanded at once. To do so: 

1. Hold Shift plus Ctrl 
2. Click on the plus sign on the tags panel “Tags” 
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Acrobat has standard tags used to define pieces of content. Most have a preceding standard tag icon 
(however certain tags have unique icons such as paragraphs and tables): 

  
Within each tag will either be additional tags or content. Content is preceded by a box icon: 

 
To see the visual location of the content in the PDF, select the content or tag containing the content in 
the tag tree, a blue box will appear around the content in the PDF: 
 

 
 
If the content does not highlight, ensure the proper setting by: 

1. Selecting the options icon 
2. Ensuring the Highlight Content option is checked 

  

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#standard_pdf_tags
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Retagging a Document 
Acrobat Pro has a functionality for automatically tagging an untagged PDF document or a document that 
needs to be retagged. Even if you converted from Office using the Acrobat add in, it’s a good idea to 
compare that tagging with this retagging. The idea is to use the best initial tagging (based on the proper 
tagging techniques for content discussed in proper tagging for common elements) to start working from.   

There are two methods to retag: 

Method 1: 

1. Select the View Menu from the top navigation bar  
2. Choose Tools, Accessibility, Add Tags to Document. 

 

  

Method 2: 

1. From the tags panel, right click the top ‘Tags’ tag 
2. Select Delete Tag 
3. Right Click ‘No Tags Available” 
4. Select Add Tags to Document 
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Moving Tags and Content in the Tag Structure 

Assistive technology will read the content in the order it appears in the tag structure. Reading order 
issues can be introduced in the conversion or initial tagging process so it is important to ensure the tag 
structure reflects the logical reading order of the document. Moving a tag may also be needed to ensure 
the proper structure of more complex content such as lists and tables. To move: 

1. Select the tag or piece of content you want to move 
2. Drag the tag or piece of content to the location you want. (As you drag, a line appears at 

viable locations) 

Most common moves you will perform: 

• Moving a tag up or down in the structure to fix a reading order issue 

 
• Moving a tag to be a child of another tag to ensure proper structure such as a list 

 
• Moving a piece of content to an empty tag 

 
• Moving a piece of content from one tag to another such as a paragraph that split across a page 

 
 

Notes: 
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• To get a high level view of the reading order you can use the Touchup reading order tool which 
will show the basic order of the content on the page 
 

  
• It is not recommended to use the touchup reading order tool to fix reading order issues as it 

may cause additional issues in the tag structure  
• If ever there is a disconnect between the order displayed in the touchup reading order tool and 

the tag structure, go by the tag structure 
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Finding Tagged Content from the Document Panel 
When a document has a great deal of tags, it is sometimes difficult to find which content belongs to 
which tag and vice versa. These steps will help find the tagged content you are looking for. 

1. Select the Tool Select tool icon from the top menu bar 

 
 

2. Select text, an image, or a table from the document panel 
3. Select the Options menu at the top of the Tags pane and then select Find Tag from Selection. 

 
4. This will highlight the tag or tags that contain the content you previously selected. 

 
5. If the content is untagged, you will get a message that reads “The Selection was not found” 
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Modifying Tags 
When a piece of content is incorrectly tagged, the tag needs to be updated. This can either be done 
directly in the tag tree or using the touchup reading order tool. While the touchup reading order tool 
might be easier, not all tags are available with this method.  

Method 1 

1. From the tags panel, right click the desired tag 
2. Select Properties 
3. Select the new tag from the Type dropdown 

 

Method 2 

1. Select Tools from the right-hand menu 
2. Select Accessibility > TouchUp Reading Order. 
3. Highlight the desired content by drawing a back around it 
4. Choose the appropriate button (Text, Figure, Table, Form Field, etc.) from the tool (Or right click 

and select from the menu). 
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5. Changes will be reflected in the Tags Panel. 

 

Notes 

• Method 2 can also be used if a piece of content is not tagged 
• When using method 2, if you do not highlight the entire content that is contained in a single tag, 

the part you highlighted will be contained in the new tag and the rest will remain in the original 
tag 

• Using method 2 can also cause visual content to “disappear”. In most cases this can be 
recovered, which is described in the tips and tricks section at the end of this document 

• You may find it easier to use method 2 and select a random tag initially (suggest Heading 6), 
then use method 1 to update to the desired tag 
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Adding Tags 
Tags can be added directly into the tag structure. This can come in handy when building structured 
elements such as lists or tables, or if a piece of content needs to be moved into a new tag. To add: 

1. Navigate to the tag structure 
2. Select a tag 
3. Right click and select New Tag 
4. Select a new tag from the dropdown  
5. Select Ok 

 
6. The new tag will be placed underneath the tag selected in step 2 at the same level 

Notes 

• Once the new tag has been added, move into the desired position in the tag tree 
• Existing content (tagged or untagged) can be brought into the tag by moving or: 

1. Highlighting the content in the document 
2. Right clicking the new tag 
3. Selecting Create Tag from Selection 
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Removing Content/Tags from the Tag structure 
Not all content included in the PDF should be in the tag structure. Upon conversion or initial tagging, 
there may be background elements such as carriage returns or lines for separation, and decorative 
images that do not convey information. Leaving these elements in the tag structure has the potential to 
confuse those who rely on assistive technology to interpret the page. You can remove decorative and 
irrelevant page elements from the tag structure without changing the visual look and feel of the 
document. This will hide the content from assistive technology users. Tagged content can be hidden 
with two methods: 

Method 1 

1. Go to the page of the content 
2. Select the touchup reading order tool 

 
3. Select the content on the page (either select the number that encompasses the content, or use 

the mouse to draw a box around the content) 
4. Select the Background button 

 

If the touchup reading order window is closed: 

1. Right click the content 
2. Select Tag as Background 
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Method 2 

1. Find the content in the tag structure 
2. Select the content (not the tag that contains the content) 

 
3. Right click and select Change Tag to Artifact 

 
4. Keep the defaults and select OK 

 
Deleting Empty Tags 
Simply deleting these tags from the structure when they contain content will prevent them be being 
seen by assistive technology but these untagged elements will then be flagged by the Accessibility 
Checker. Therefore only delete a tag that is empty! To do so: 

1. Select the empty tag from the tags panel 
2. Right click and select and select Delete Tag 
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Notes 

• Additional Resources 
o https://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF4  

 

  

https://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF4
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Proper Tagging for Common PDF Content 
This section explains the proper end tagging for common contents of a PDF.   

Paragraphs 

Paragraph tags should be used on visual paragraphs in the document and plain or decorative text that 
stands on its own which is not acting as a heading. 

  

<P> - Paragraph tag, used to encompass a single paragraph or standalone piece of text 
 

Correct Implementation 

 

 
 

Notes 

• Text of visual paragraphs that span across pages should be contained in a single paragraph tag 
• Other contents within a single visual paragraph that require additional unique tags, such as a 

footnote reference or a link, should also be contained in a single paragraph tag 
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Headings 
Heading tags should be used on text that was visually modified to act as a heading / define a section of 
text in the document. There are 6 levels of tags that should follow a logical progression (no skipping 
levels) as sub sections are introduced. 

  

<H1> - Heading level 1 tag, in most cases used a single time to encompass the main title of the 
document  
<H2> - Heading level 2 tag, in most cases used to encompass main sections or chapters of the document 
<H3> through <H6> - Used as necessary to encompass headings that are subsections of the previous 
level 

Correct Implementation 
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Notes 

• Only use heading tags on pieces of text that define a section of content 
• Text with a different look and feel does not necessarily make it a heading 
• Recommend only using H1 once to tag the title of the document 
• If heading levels past 6 are necessary, recommend using a Span tag on the content with the 

following technique: 
1. Select the span tag and right click 
2. Select Copy contents to clipboard 
3. Select the span tag and right click 
4. Select Properties 
5. Type Heading Level X in the Actual text field (X being the desired level) 
6. Paste the contents into the text field 

 
• Additional Resources: 

1. http://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html#PDF9  

 

 
 
  

http://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html#PDF9
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Lists 
List tags should be used on sequential items that are either numbered or bulleted. This ensures visual 
lists, including the number of items, are properly announced to assistive technology.  

 

<L> - Main list tag, contains at least 1 <LI> tag and is used to encompass a single visual list 

<LI> - List Item tag, contains 1 <Lbl> and 1 <Lbody> tag and is used to encompass a single item in the list 

<Lbl> - Label tag, used to encompass the item number or bullet character. 

<LBody> - List body tag, in the case of a nested list contains a <L> tag, and is used to encompass the 
content of the list item 

 Correct Implementation (Simple List) 
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Correct Implementation (Nested List) 

 

Notes 

• The label tag is considered optional, but the bullet or number must be contained in the <lbody> 
tag if omitted 

• Bullets are considered informational and must not be set to background 
• In cases where a numbered item is separated by paragraphs of text, headings are recommended 
• Additional Resources 

o https://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF21  

 

 

  

https://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF21
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Figures 
Figure tags should be used on visual images that convey information. The alternate text property of the 
figure tag should contain text that conveys the same information a sighted user gains. 

  

<Figure> - Figure tag, used to encompass a single image, or group of related images and or content. 
 

Add/Modify Alternative Text of a Figure 

There are two ways to add alternate text to a Figure. 

Method 1 

1. Select the TouchUp reading order tool 
2. Right click on the figure  
3. From the drop down menu select “Edit Alternative Text” 
4. Modify the Alternate Text field 

 

Method 2 

1. Locate the figure in the tag panel 
2. Right click the figure tag 
3. Select Properties 
4. Select the Tag Tab 
5. Modify the Alternate Text field (Do not use the actual text field) 
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Correct Implementation 

 

Notes 

• Whatever content the figure tag encompasses will be replaced by the alt text field in terms of 
what is read to assistive technology 

• There is no official limit on the alt text field, however best practices recommend limits ranging 
from 120-250 characters. As such, complex images should adhere to the following guidelines: 

• http://www.w3.org/WAI/tutorials/images/complex/ 
• http://webaim.org/techniques/alttext/#complex  

• Additional Resources: 
• http://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF1 
• http://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF4 

 
 
 

 

  

http://www.w3.org/WAI/tutorials/images/complex/
http://webaim.org/techniques/alttext/#complex
http://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF1
http://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF4
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Links 
Link tags should be used on physical hyperlinks that take users to a destination such as a location in the 
same document or a URL.  

 

<Link> tag contains the link text of the physical hyperlink and a Link–OBJR tag which enables assistive 
technologies to properly recognize the link and handle it correctly. 

Correct Implementation 

 

 
Notes: 

• This tagging applies for all physical hyperlinks in Acrobat. Even though a URL may be present in a 
PDF, it is not hyperlinked unless there is a physical link present. To check for physical links: 
1. Navigate to the desired page of the PDF 
2. In the content editing tool, select Add or Edit Link 
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3. Physical links will have a blue box appear around them, and will have an additional menu 
appear when right clicked 

 
4. If a physical link should be present but is not, it can be added but be sure to follow the steps 

in the Add/Modify Links section of this guide to add a Link-OBJR tag 
 

• On the flip side, if you find a physical link that should not be there, it should be deleted 

 
•  The order of the Link-OBJR and link text does not matter 
• Additional Resources: 

o https://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html#PDF11  
 

 

 

  

https://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html#PDF11
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Language of Foreign Words or Phrases 
When a word or phrase appears in the document that is a different language then the main language of 
the document, the tag containing that word or phrase must have the language properly set so screen 
readers can correctly announce the content. 

Correct Implementation 

The tag containing the foreign phrase has the language correctly set in the properties: 

 

Notes 

• In situations where the word or phrase is in the same sentence, use a Span tag for only the word 
or phrase and set the language of the Span tag. 

• Additional Resources: 
• W3 PDF Technique #19 

 
  

http://www.w3.org/TR/2015/NOTE-WCAG20-TECHS-20150226/PDF19
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Table of Contents 
Table of Contents tags should be used on the visual table of contents of a document. 

  

<TOC> - Main Table of Contents tag, contains at least 1 Table of Contents Item tag and used to 
encompass an entire table of contents instance 
<TOCI> - Table of Contents Item tag, may contain another tag such as paragraph or Link/Reference and 
used to encompass the content of the visual table of contents entry 

Correct Implementation 

 

 
 

Notes 

• Multiple table of contents can exist in a single document, for example if there is an additional 
list of tables, figures, etc. 

• If the table of contents is physically linked, each Link-OBJR should appear in the Link/Reference 
tag for each table of contents item 

• Some resources have both a reference and a link tag 
• Best practices are to mark the leaders (……….) as background 
• Additional Resources: 

o https://www.w3.org/TR/WCAG20-TECHS/G64.html  

  

https://www.w3.org/TR/WCAG20-TECHS/G64.html
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Footnotes/Endnotes 
Reference and Note tags should be used on citations within the main body and the corresponding foot 
or end note respectively. 

  

<Reference> - Reference tag, used to encompass a citation in the main body of the document 
<Note> - Note tag, contains a label tag and used to encompass the footnote/endnote text 
<Label> - Label tag, used to encompass the citation in the footnote/endnote that corresponds to the 
citation in the reference 
 

Correct Implementation 

 
 

Notes 

• The Label tag is optional under the Note tag 
• Suggest removing any physical links for same page footnotes 
• There is no single standard for setting the order for footnotes or endnotes 

o Suggest putting the Note tag immediately following the main tag containing the 
Reference (such as a Paragraph, Table, List, etc.) so as not to disrupt the flow of the 
main content 

o However, you can also put the Note tag immediately after the Reference tag or; 
o Or at the end of the page or document  

• One thing you should not do is have the Note tag split an unrelated paragraph (can occur on the 
initial tagging when a page contains a footnote and a paragraph that starts on the page and 
finishes on the next)  
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Tables 

Table tags should be used only on visual data tables and need special tagging to ensure 
understandability and relationships between header cells and data cells. 

  

<Table> - Main table tag, contains at least 1 <TR> tag and is used to encompass a single visual data table 
(including tables that span multiple pages) 

<TR> - Table Row tag, contains 1 <TH> and or <TD> tag and is used to encompass a single row of a data 
table 

<TH> - Table Header tag, used to encompass data table cells that are header cells (header cells define 
data cells) 

<TD> - Table data cells, used to encompass data table cells that are purely data 

Ensuring structure 

Coding HTML data tables for accessibility is almost exactly like tagging PDF data tables for accessibility. 
As such if you have a developer resource, they should be able to aid you in obtaining the correct 
structure of your table. Good structure depends much on how the table was created in the source 
document, but even a good structure can get altered on the conversion. Acrobat has a built in table 
editor to aid. To use: 

1. Open the Touchup reading order tool 
2. Select the table 
3. Select Table editor 
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Acrobat will then draw lines based on the current tagging to give a visual representation of the table. 
Properties of individual cells or groups of cells can then be modified. To do this: 

1. Select a cell 
2. To select multiple cells, hold shift while selecting additional cells 
3. Right click and select Table cell properties 

 

In particularly complex tables, the table editor may become unresponsive at times and you’ll have to 
modify properties within the tag structure. To get an accurate view of the table structure at any point, 
we recommend using the PAC PDF Accessibility Checker 2.0., in particular the screen reader preview 
which will give you the programmatic view of your table structure that you can use to diagnose issues. 

http://www.access-for-all.ch/en.html
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Setting column and row spans 

If you have a cell that spans more than 1 row and/or column of a table, you need to ensure the Row 
Span and Column Span values are correctly set. There are two methods. 

Method 1: 

1. Open the table editor 
2. Select the Cell 
3. Right click and select Table Cell Properties 
4. Set the appropriate values for Row and/or Column Span 

 

Method 2: 

1. Open the Tag structure 
2. Select the Cell 
3. Right click and select Properties 
4. Select Edit Attribute objects 
5. If attribute objects exist, expand and select existing Row Span or Column Span (if not, skip to 

step 8) 
6. Select the attribute and select Edit Attribute 
7. Set the correct values and click OK 
8. If attribute objects do not exist 
9. Select New Item 
10. Modify the auto-generated /O attribute from Layout to Table 
11. Select New Item 
12. Set the Key to either Row Span or Column Span (Capitalization matters) 
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13. Set the value appropriately 
14. Set the Value Type to Integer 

 

Setting Header cells 

Once the structure is correct, the header cells must be defined as TH cells. Either change the appropriate 
TD cells to TH cells in the tag structure or use the table editor to make the change (multiple cells can be 
changed at one time in the table editor). 

 

Setting Scope 

If the data table has one set of column and one set of row header cells, scope will need to be set. 
Header cells that define a column need to have scope set to column. Header cells that define a column 
need to have scope set to Row. Either set the scope through the table editor (multiple cells can be 
changed at one time) 

 

Or set the scope through the attribute objects. In this case: 

1. Modify the existing value or;  
2. Add a new item 
3. Modify the auto-generated /O attribute from Layout to Table 
4. Set the Key to Scope (Capitalization matters) 
5. Set the value to either Row or Column 
6. Set the Value Type to Name 
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Setting ID/Headers 

If the data table has more than one set of column and/or row header cells, a more complex method 
needs to be used. Header cells will need to be given unique ID’s and correctly associated to the 
appropriate data cells they define. Either set the ID’s and associations through the table editor (Only 
one cell can be set at a time) 

 

Or set the ID through the properties of the TH tag  

 

And set the association of the headers in the attribute objects. In this case: 

1. Modify the existing value or;  
2. Add a new item 
3. Modify the auto-generated /O attribute from Layout to Table 
4. Set the Key to Headers (Capitalization matters) 
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5. Set the Value Type to Array 

 
6. Select the new Headers item 
7. Add a new item 
8. Set the Value to the ID of the header cell 
9. Set the Value Type to String 

 

Correct Implementation 

 
Notes 

• Additional Resources: 
1. https://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html#PDF20 
2. https://www.w3.org/WAI/tutorials/tables/   

https://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html#PDF20
https://www.w3.org/WAI/tutorials/tables/
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Container Tags 

Some standard Acrobat tags are considers container tags that are used purely to section out other tags. 
They are not required to make a document accessible, however on initial conversions there can be an 
abundance where you have to drill down levels to get to the actual content.  
 

 
 
<Document> - Main document tag used to encompass all the tags and content in the tag structure 
<Part> - Part tag used to encompass large parts of tags and content 
<Div> - Division tag used to encompass groups of tags and content 
<Art> - Article tag used to encompass a standalone group of tags and content 
<Sect> - Section tag used to encompass a section of tags and content in a Part or Article 
 

Notes 

• Suggest cleaning up the container tags as a final activity if time allows.  
• Container tags do not negatively affect accessibility and will not cause any issues in the 

accessibility checker  
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Role Mapping 

On conversion, custom tags can be added to the tag structure. While it is preferred to always use the 
standard Acrobat tags, at the very least each of the custom tags must logically map to a standard tag. 

To see if a mapping exists: 

1. From the tags panel select the options icon 
2. Select Edit Role Map 

 
3. Expand the Document Roles 

If mapping for a custom tag does not exist: 

1. Select Document Roles 
2. Select New Item 
3. Type the name of the custom tag 
4. Select the appropriate standard tag from the dropdown 
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Correct Implementation 
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Bookmarks 
When the PDF has more than 9 pages, it needs to have bookmarks. Bookmarks are best added at the 
end when the heading structure tagging is finalized. To add bookmarks based on the structure: 

1. Select the Bookmark icon 
2. Select the Options icon 
3. Select New Bookmarks from Structure 

 
4. Select the elements to include (suggest selecting all headings H1-H6) 
5. Select all bookmarks (except Untitled) 
6. Move up one level 
7. Right click the Untitled bookmark 
8. Select Delete 
9. Open the Bookmarks panel by clicking the “Bookmarks” button in the Navigation Bar in the 

Navigation Pane. 
10. Click the “New bookmark” button at the top of the panel to add a new, untitled bookmark to 

the panel. 
11. Type a name for the new bookmark and press “Enter.” The bookmark will be highlighted in the 

panel. 

Bookmarks can also be added manually through two methods: 

Method 1: 
1. Navigate through the PDF to find the text you want to link to the bookmark. 
2. When you have the size and location of the bookmark where you want, click the “Options” 

button in the toolbar at the top of the Bookmarks panel and then choose the “Set Bookmark 
Destination” command from the drop-down menu. 

3. Click “Yes” in the pop-up message that appears to ask you to confirm the location for the 
bookmark to apply a bookmark to the page. 

Method 2: 

1. Choose the Selection Tool from the Common Tools toolbar. 
2. Click and drag over the text that you want to bookmark to select it. 
3. Click the “New Bookmark” button at the top of the Bookmarks panel. 
4. A new bookmark appears in the Bookmarks panel, with the text you highlighted shown as the 

name of the bookmark. This feature is handy because it both names the bookmark and 
automatically links the bookmark to the highlighted text, saving you the step of setting the 
bookmark destination. 
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Checking the Accessibility 
Once you feel you are done tagging the PDF, be sure to do a couple basic accessibility checks to ensure 
nothing was missed.  

Accessibility Checker 
There is a built in accessibility checker in Acrobat.  Although it does not guarantee a compliant 
document (even if it passes all checks), it does show basic errors. A fail for any of the checks means the 
document is probably not compliant.  

Steps to Check: 

1. Open the PDF. 
2. Select View > Tools > Accessibility. 
3. Select Full Check and keep the defaults. 
4. Select Start Checking. 
5. Expand any category denoted with issues. 
6. Inspect the results. 

Correct Example 

There are no fails in the accessibility checker. Any issues flagged are ones that need manual checks: 

 

Notes 

• A clean report does not necessarily mean a compliant document, the tag structure must still be 
inspected manually. 

• Most flagged errors are issues found in the tag tree. To further analyze the error, right click on 
the error and select Explain. An Acrobat help page will be displayed with an explanation and 
instructions to fix. 
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• To find specific instances of the errors, expand and select the individual elements which usually
highlights the element in the main view of the document when ‘highlight content’ is enabled.

• If available, Show in Tags Panel and Show in Content Panel can take you directly to the element
with the issue.

• Additional Resources:
o https://helpx.adobe.com/acrobat/using/create-verify-pdf-

accessibility.html?trackingid=KACNN#check_accessibility_of_PDFs

https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html?trackingid=KACNN#check_accessibility_of_PDFs
https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html?trackingid=KACNN#check_accessibility_of_PDFs
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Saving as Text 
Though text may look accurate visually, on the back end there may be typos or additional spacing that 
will cause screen readers to announce incorrect content. This can occur in any document, but is more 
common to occur when a program other than Office was used to construct the original document.  

Steps to check: 

1. Open the PDF. 
2. Select File > Save as other > More Options > Text (Plain). 
3. Select a save location. 
4. Select Save. 
5. Navigate to and open the text file in Word 
6. Using built in tools for grammar and spell checking, look for typos or spacing issues 
7. Compare results to the visual document. 

Correcting mistakes 

These kinds of text errors usually are introduced because of something in the source document. Ideally 
these issues should be diagnosed so they are not introduced in future documents. However, they can be 
addressed in the PDF: 

1. In the tag panel, right click the tag containing the inaccurate text 
2. Select Copy Contents to Clipboard 

 
3. Right click the tag containing the inaccurate text 
4. Select Properties 
5. Paste into the Actual Text field 
6. Correct the inaccurate text 
7. Select Close 
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If there is a piece of inaccurate text in a long passage, suggest tagging the piece of text with a span tag 
and setting the Actual Text field of the Span tag appropriately (rather than pasting the entire passage 
into the Actual text field of the original tag) 

 

Notes 

• This issue will NOT be caught by the Acrobat Accessibility checker. 
• Reading order issues will also be reflected in the text file. 
• Alt text of images will be included in the document, so typos can be spotted there as well 
• The initial save as the text file seems to replicate the closest experience as to what assistive-

technology users’ experience, as such it is NOT recommended to save directly as a Word file in 
this evaluation. 
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Content Editing 
It’s important to ensure the document is in the final state for posting before beginning the tagging 
process. If minor changes are required, they can be made on the actual PDF to avoid having to update 
the source document, convert to a new PDF, and having to restart the tagging process. 

These editing features can also be used if you are tagging a document you have not authored, and 
encounter issues such as conveying information with color, low contrast, and content needing an 
alternate accessible version.  

Add/Modify Text 

Text can be added or modified: 

 

• If adding new text, be sure to tag the new text and place it in the appropriate position in the tag 
tree 

• If editing text, be sure to recheck the tag containing the original content to ensure the edited 
text is accurate 

• Editing text can also be used to adjust text color in cases of low contrast 
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Add/Modify Images 

Images can be added, adjusted or deleted: 

 

• If adding new image, be sure to tag the new image, give appropriate alt text, and place it in the 
appropriate position in the tag tree 
 

Add/Modify Links 
Hyperlinks can be edited or added to any part of the document (though recommend only linking actual 
text) 

 

• If adding a new link, the LINK-OBJR tag will need to be added and placed appropriately in the tag 
structure (as explained in the Links section of this document)  

1. From the tag structure, select the parent Link tag (should currently only contain the link 
text) 

2. At the top of the tags panel, select the menu icon 
3. Select Find 

 
4. Select Unmarked Links from the dropdown 
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5. Select Find 

 
6. The link without an Link-OBJR tag should highlight, if not, select Find Next until it does 
7. Select Tag Element 

 
8. The Link-OBJR tag should now appear under the Link tag. 

 

Add Pages from File 

Additional pages can be added to the document through the following steps: 

1. Select the page thumbnails icon  
2. Select the page before or after where the new page will be inserted 
3. Right click and select Insert Pages > From File 

 
4. Configure the desired settings and select OK 
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After added, any tags from the new file will be added to the bottom of the tag structure, be sure to 
place them in the appropriate position on the tag tree and/or tag the new content as needed. 
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Perform OCR on Scanned Document 
A common method for making PDF documents is to place a paper copy of a document into a scanner and 
view the newly-scanned document as a PDF with Adobe Acrobat. Unfortunately, scanners only create an 
image of text, not the actual text itself. This means the content is not accessible to users who rely on 
assistive technology. Additional modifications must be made to make the document accessible. 

How to determine if a PDF File is a Scanned Document 

The Page Appears to be skewed  

Sometimes sheets are not properly position into the scanner. The result is the page appears to be 
crooked, or skewed on the screen.  

 

Search for Characters that Appear on the Page  

Use the find command in Acrobat to search for text that appears on the page. Select Edit > Find and type 
a term that appears on the page in the search field.  

If the document was scanned, Acrobat will not find the search item but will display the message: 
“Acrobat has finished searching the document. No matches were found.”  

Performing Optical Character Recognition (OCR)  
Activate View > Tools > Text Recognition > Choose In This File/In Multiple Files 

   
 
Keep default settings and select OK. After completion, use the methods described in this document to 
ensure proper tagging. 
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Tips and Tricks 

1. To get a full view of the tag structure, click on the  plus sign while holding down 
Shift + Ctrl.  

2. For large documents with complex content, you may have trouble tagging with the techniques 
discussed. In these cases, try isolating the page you are having trouble with as it can lead to a 
better tagging experience. To extract pages: 

a. Select the desired page(s) from the Page thumbnails view 
b. Right click and select Extract pages 

 
c. Select additional settings as desired and select OK 
d. After tagging the pages separately they can be merged back into the original document 

by deleting the original page and adding the new page from file.  
3. If you are working on a PDF you have not authored and find a complex piece of content that 

needs an alternate version, suggest using the content editing methods to either: 
a. Providing a link to an accessible version of content that already exists or; 
b. Creating an alternate version in Word to be added at the end of the document and 

adding a link to that page next to the original 
4. If you are working on a PDF you have not authored, tagging is proving difficult, and identical look 

and feel is not required. Try saving as a Word file, making adjustments to the Word file and 
reconverting back to PDF. 

 
5. Sometimes during tagging, text can ‘disappear’ if it is on top of an image. To remedy: 

a. Use the Edit Text & Images feature 
b. Find the outline of the text and select 
c. Right click and select Arrange > Bring to Front 
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d. The hidden text should reappear 

 
 
  

Additional Resources 
• PDF techniques for WCAG 2.0 
• Adobe accessibility help 
• HHS Making files accessible 
• Webaim – PDF Accessibility 

 

 

 

https://www.w3.org/TR/2014/NOTE-WCAG20-TECHS-20140408/pdf.html
https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html
http://www.hhs.gov/web/508/accessiblefiles/index.html
https://webaim.org/techniques/acrobat/
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